Lost World and NEW3D engine

Having technical difficulties with Supermodel? Last-minute wardrobe malfunction? Get help here.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Lost World and NEW3D engine

Postby theboy181 » Mon Oct 10, 2016 12:52 pm

r494 is amazing! Thank you for such great attention to details with Model3!

I'm unsure if this has been addressed, but I was unable to find a post regarding lost world and the new3d engine. The 2d overlays during the cut scenes are displayed at the wrong ratio, and since the fog only works in new engine, I was wondering if there was a work around to fix the issue.

Thanks and excellent work guys!
theboy181
 
Posts: 3
Joined: Mon Jun 20, 2016 8:17 pm

Re: Lost World and NEW3D engine

Postby Bart » Tue Oct 11, 2016 5:23 am

Known issue with viewports. New 3D engine implements viewports correctly, allowing them to be asymmetric, whereas old engine assumes symmetry and ignores half of the parameters. For some reason, some games don't set up the entire viewport. We suspect it's an emulation bug of some sort.
User avatar
Bart
Site Admin
 
Posts: 1997
Joined: Thu Sep 01, 2011 2:13 pm
Location: New York City

Re: Lost World and NEW3D engine

Postby theboy181 » Sat Oct 15, 2016 6:31 pm

Thank you for the reply.

Emulator is not actively being worked on? just the new3d engine?
theboy181
 
Posts: 3
Joined: Mon Jun 20, 2016 8:17 pm

Re: Lost World and NEW3D engine

Postby Bart » Sun Oct 16, 2016 7:14 pm

That is more or less correct. I have some work in the pipeline but it's mostly behind the scenes.
User avatar
Bart
Site Admin
 
Posts: 1997
Joined: Thu Sep 01, 2011 2:13 pm
Location: New York City

Re: Lost World and NEW3D engine

Postby Ian » Mon Oct 17, 2016 5:20 am

The new3d engine is nearly done. There's only a few things left I want to add, namely specular. There are also a few unimplemented fog functions to do with the light.
Ian
 
Posts: 1122
Joined: Tue Feb 23, 2016 9:23 am

Re: Lost World and NEW3D engine

Postby terminento » Mon Oct 17, 2016 2:16 pm

OMG specular!
Then the only thing left to have the Lost World be perfect would be the squished user interface!
But, hey, perfect Daytona 2 as well!
Oh... the excitement! LOL
User avatar
terminento
 
Posts: 158
Joined: Fri Jun 15, 2012 8:08 am

Re: Lost World and NEW3D engine

Postby Ian » Mon Oct 17, 2016 2:17 pm

well
currently specular exists in the new engine, but I disabled it as it looks completely broken in games like sega rally ..
Ian
 
Posts: 1122
Joined: Tue Feb 23, 2016 9:23 am


Return to The Fitting Room

Who is online

Users browsing this forum: No registered users and 2 guests