Sega Rally 2 (SM version r506) Music Problem

Having technical difficulties with Supermodel? Last-minute wardrobe malfunction? Get help here.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Will this problem be fixed?

Poll ended at Thu Dec 22, 2016 12:54 pm

Yes
2
100%
Nope
0
No votes
 
Total votes : 2

Sega Rally 2 (SM version r506) Music Problem

Postby TheRealDise » Thu Dec 08, 2016 12:54 pm

Have you ever noticed the difference between real hardware and fake emulation? I have.

Here is gameplay on a real machine of Sega Rally 2:
https://youtu.be/DK44gIhJ9ng

Here is Supermodel gameplay, on the latest SVN of 0.3 .
https://www.youtube.com/watch?v=DZkJMzexuEc

Noticed it? If you have, it's to do with the music. On real hardware, when you finish a stage, the right music plays straight away. (Demonstration: https://youtu.be/03F9twxDL60?t=3m15s) On Supermodel, the right music DOES play (it's called Goal), it just doesn't play right away. When the weirdo says "FINISH!!!", the music should play as soon as he says "FINISH!!!". On Supermodel, however, it waits until guy finishes saying "FINISH!!", and then finally play the music.

This also happens when the Goal music finishes, or when you have selected all choices on the menu (that music is called Ignition 98'). It should get quieter until it's silent when the "**COURSE NAME** START!" shows. If however doesn't until the next music plays.

This ALSO happens in the attract mode no matter what country the machine is set to. When it shows the game logo, the music should fade away, which it does on Supermodel, but when the SEGA logo shows, the music is really LOUD. It should stop until the attract intro plays again.

Bart and Nik, PLEASE fix this problem if you can. Fixing these problems will be very handy for people with MAME (multiple arcade machine emulator) machines!
User avatar
TheRealDise
 
Posts: 40
Joined: Thu Dec 01, 2016 11:20 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby Bart » Fri Dec 09, 2016 12:07 am

We are aware of these problems but unfortunately, don't yet know how to fix them. This has to do with emulation of various MPEG board commands that are not well understood. Someone has been looking at them and made some potential progress, though, but we can't guarantee anything will be fixed.
User avatar
Bart
Site Admin
 
Posts: 2063
Joined: Thu Sep 01, 2011 2:13 pm
Location: New York City

Re: Sega Rally 2 (SM version r506) Music Problem

Postby Ian » Fri Dec 09, 2016 3:30 am

I'd love to be able to do something useful with the audio code. But I don't think non programmers understand sometimes it can take weeks to really get your head around other peoples code so that you can make useful changes. And then you have the impossible task of reverse engineering a system based upon no documentation.
Ian
 
Posts: 1233
Joined: Tue Feb 23, 2016 9:23 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby TheRealDise » Sat Dec 10, 2016 4:24 am

Bart wrote:We are aware of these problems but unfortunately, don't yet know how to fix them. This has to do with emulation of various MPEG board commands that are not well understood. Someone has been looking at them and made some potential progress, though, but we can't guarantee anything will be fixed.

Probably try putting some of this in the next SVN maybe? Hopefully I'm not saying anything to be rude xD
Loading... Loading... Finished loading.
Code: Select all
I have a low FPS problem in the latest SVN. Help!! See my thread
User avatar
TheRealDise
 
Posts: 40
Joined: Thu Dec 01, 2016 11:20 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby Joaquim Gonçalves » Sat Dec 10, 2016 5:35 am

Bart wrote:We are aware of these problems but unfortunately, don't yet know how to fix them. This has to do with emulation of various MPEG board commands that are not well understood. Someone has been looking at them and made some potential progress, though, but we can't guarantee anything will be fixed.


In my opinion Haze should be great to do this, i still remember when it fixes Raiden versions. But i don´t guarantee nothing. :)
Waiting...
User avatar
Joaquim Gonçalves
 
Posts: 421
Joined: Wed Dec 10, 2014 5:12 pm
Location: Portugal

Re: Sega Rally 2 (SM version r506) Music Problem

Postby TheRealDise » Sat Dec 10, 2016 9:02 am

Joaquim Gonçalves wrote:
Bart wrote:We are aware of these problems but unfortunately, don't yet know how to fix them. This has to do with emulation of various MPEG board commands that are not well understood. Someone has been looking at them and made some potential progress, though, but we can't guarantee anything will be fixed.


In my opinion Haze should be great to do this, i still remember when it fixes Raiden versions. But i don´t guarantee nothing. :)

Who's Haze? (or whats haze
Loading... Loading... Finished loading.
Code: Select all
I have a low FPS problem in the latest SVN. Help!! See my thread
User avatar
TheRealDise
 
Posts: 40
Joined: Thu Dec 01, 2016 11:20 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby Toshiko » Mon Dec 12, 2016 5:36 pm

Haze is a MAME developer. A very prolific one, at that.
Toshiko
 
Posts: 83
Joined: Fri Mar 16, 2012 10:30 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby TheRealDise » Tue Dec 13, 2016 11:10 am

Toshiko wrote:Haze is a MAME developer. A very prolific one, at that.

He might put this fix in MAME though. I'm not sure. I never use MAME, the only emu's I use are Model 2, Supermodel, and PCSX2.
Loading... Loading... Finished loading.
Code: Select all
I have a low FPS problem in the latest SVN. Help!! See my thread
User avatar
TheRealDise
 
Posts: 40
Joined: Thu Dec 01, 2016 11:20 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby Kacperas » Tue Dec 13, 2016 1:44 pm

Haze has stopped contributing to MAME (no more major development) some time ago. He said, he no longer have any real interest in doing this (it feels more like a burden for him now).
Kacperas
 
Posts: 39
Joined: Tue Sep 27, 2011 9:35 am

Re: Sega Rally 2 (SM version r506) Music Problem

Postby ConversusVans » Tue Dec 13, 2016 3:34 pm

Kacperas wrote:Haze has stopped contributing to MAME (no more major development) some time ago. He said, he no longer have any real interest in doing this (it feels more like a burden for him now).


Speaking of MAME and audio issues, I remember years ago constantly reporting bugs on MAME Testers for non-working drivers in MAME. I got banned from the site and was set to viewer. One of the bugs was actually a legitimate SCSP audio bug for Harley in MAME (where the game would play random sound effects in place of the attract music).

Boy, I used to be nag around MAME developers, asking them what specs I need to run games, reporting pointless bugs, etc. Go old me!:
http://mametesters.org/view.php?id=4425 (this was back when I had different usernames on different sites; I was "MarvelvsCapcom2")
- Conversus W. Vans (Paul)
User avatar
ConversusVans
 
Posts: 196
Joined: Sun Apr 27, 2014 3:27 pm
Location: The Abandoned Land

Next

Return to The Fitting Room

Who is online

Users browsing this forum: Bing [Bot] and 2 guests