Page 1 of 1

r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Wed Jan 24, 2018 7:45 am
by uacGalactic
Hi guys, I've run into a bit of a problem with the r700 build.

I've been running a much older version of Supermodel (circa 2015) for the last couple of years and it has served me well - however I recently wanted to be able to play games with a 16:9 ratio as I've seen done online. I learned that my current build did not support widescreen so I'd have to upgrade to a new version.

It's currently running like this: https://www.youtube.com/watch?v=FrswfFr7qGs
But I'd like to have it running like this: https://www.youtube.com/watch?v=uMuIaMkbrVc

So I upgraded and tried to launch it and the program would not launch. Then I dug further and copy/pasted the following text in the config file.
"EmulateNet=1
port_in = 1970
port_out = 1971
addr_out = "127.0.0.1"

At this point the program will launch - but with Scud Race (which is the ROM I'm testing) it will load the settings screen where you normally press '6' to change the setting but the program will not respond to any button inputs - it just hangs on the cabinet settings screen and no keystroke or input registers - I can only press Esc to exit the program.

I'm almost sure I'm doing something wrong with the netboard emulation part and that's causing the issue (or maybe not?) but I'm not sure how to fix this. The Rom I'm using is identical to the one I'm using on the old version of Supermodel and it runs fine.

The console spits out the following text:
Image

SO any help would be appreciated. I've had some experience with launching via terminal but not much. Thankyou in advance. :)

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Wed Jan 24, 2018 11:17 am
by Ian
try EmulateNet = 0
unless you want network support
But it doesn't work in scud yet

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Wed Jan 24, 2018 11:35 am
by uacGalactic
Ian wrote:try EmulateNet = 0
unless you want network support
But it doesn't work in scud yet


Tried that and still hangs at the same spot, unfortunately.

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Sun Jan 28, 2018 9:26 am
by uacGalactic
Anybody have any other ideas? Bart?
I'm at a total loss here I've tried to troubleshoot this myself but cannot find a solution. Thanks.

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Sun Jan 28, 2018 11:51 am
by Ian
Try the latest version

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Sun Jan 28, 2018 12:00 pm
by uacGalactic
Ian wrote:Try the latest version


Isn't r700 the latest version?

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Sun Jan 28, 2018 12:05 pm
by Ian
nope :p

Re: r700 build hangs on cabinet settings screen (Windows 10)

PostPosted: Sun Jan 28, 2018 12:16 pm
by uacGalactic
Ian wrote:nope :p


Do you know where I can find the latest version?

On the forums here it lists that as the latest build? "Supermodel Latest Builds for Download (currently SVN 700)"

edit: actually nvmnd I seem to have figured it out :)