Lastest Build WIP r775 Discuss (do not post builds) DAT+BAT*

Discuss Supermodel and your favorite Model 3 games. Show off your latest threads, this is the place to see and be seen.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Ian » Mon Aug 13, 2018 6:12 am

Toshiko, what gfx card do u have? Maybe i'll try and have to get my hands on an AMD card. I have one, but it's super old and not really much point in testing with.
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Toshiko » Mon Aug 13, 2018 6:40 am

It's an RX 480.

And yeah, AMD's OGL drivers are famously terrible, but at least I have't personally suffered their impact all that often. There was about a 3 week period where I had to use a much less efficient rendering mode in Photoshop two cards ago, a two week period where a game on Steam had hilariously broken textures, and everything else has been only occasional weird behavior in Supermodel, PCSX2, and N64 video plugins. I haven't personally done much work in emulation, and won't moan about the behavior of something I didn't pay money for, but I'll report something not behaving as intended if nobody else has.
Toshiko
 
Posts: 123
Joined: Fri Mar 16, 2012 10:30 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby YoYo09 » Mon Aug 13, 2018 8:06 pm

Ian
Virtua Fighter 3tb Pai Stage
Can I fix the blinking bad polygon in the background?
And the pai clothes texture problem

Bad polygon scene save file
https://drive.google.com/file/d/1JuA1Jz ... sp=sharing

Add
The white line Symptoms was visible again.
From Le Mans 24 Demo (It appears partially in multiple scenes )

save file
https://drive.google.com/file/d/1IiYoKg ... sp=sharing

From R737 LeMans 24 will not boot
After booting from the previous version, I saved and tested it.
Attachments
le.JPG
le.JPG (66.04 KiB) Viewed 2642 times
p.JPG
p.JPG (48.3 KiB) Viewed 2674 times
YoYo09
 
Posts: 70
Joined: Mon Nov 28, 2016 7:43 pm

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Ian » Tue Aug 14, 2018 1:16 am

Add
The white line Symptoms was visible again.
From Le Mans 24 Demo (It appears partially in multiple scenes )


Could well still be a div by zero happening in the shaders that I've missed. I'll have a debug on my nvidia card and see what happens.

Not sure why lemans doesn't boot .. will have to look into it.
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Ian » Tue Aug 14, 2018 5:59 am

I checked out the lines in lemans24. They are present in the normal triangle version too, so it's not quad rendering related. For polys to not have gaps, they must use exactly the same vertex positions, which in the case of some of the models3 games they appear not to. I'll attempt to get an oldish but capable enough amd card for testing.
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Toshiko » Tue Aug 14, 2018 7:18 am

I have a Radeon HD 6870 that's currently doing an excellent job at keeping papers from floating away, but it hasn't had driver updates in over two years, and you could probably get one locally for less than the cost of shipping it over the Atlantic to you :lol:
Toshiko
 
Posts: 123
Joined: Fri Mar 16, 2012 10:30 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Ian » Fri Aug 17, 2018 6:43 am

Toshiko wrote:I have a Radeon HD 6870 that's currently doing an excellent job at keeping papers from floating away, but it hasn't had driver updates in over two years, and you could probably get one locally for less than the cost of shipping it over the Atlantic to you :lol:


Could you test the quad build on that gfx card?

I would be interested to know if this bug still exists on it
Image

If so maybe I could pick up one of these gfx cards cheap just for testing with. Really don't want to spend £100+ on another gfx card.
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Toshiko » Fri Aug 17, 2018 11:37 am

Sure! I have an older desktop in the living room I can throw it into. My wife's desktop has a slightly newer (I think HD 7870? It just met the cutoff for Vulkan support) AMD card than that, as well. I'll test both.
Toshiko
 
Posts: 123
Joined: Fri Mar 16, 2012 10:30 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Toshiko » Fri Aug 17, 2018 2:30 pm

I can report that it is hilariously broken on the two older AMD cards. XD

Vehicle models are displayed exactly as intended, but the track geometry warps reminiscent of the way many Saturn games do when quads reach past the edge of the screen, only much, much moreso. A couple quick screenshots:

Image

Image
Toshiko
 
Posts: 123
Joined: Fri Mar 16, 2012 10:30 am

Re: Lastest Build WIP r738 Discuss (do not post builds)

Postby Ian » Fri Aug 17, 2018 3:00 pm

Yeah that's a known driver bug. I found it originally with my hd5360 or something card, which is super old, maybe 10 years old. It's why I never attempted to release the code originally. AMD fixed it in their new drivers, but I had no idea at what point these got rolled out to end users.

I am wondering if that other issue is also a driver bug. Hard to tell unless I can get my hands on a card that can replicate it.
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

PreviousNext

Return to The Catwalk

Who is online

Users browsing this forum: No registered users and 6 guests

cron