Lastest Build WIP r775 Discuss (do not post builds) DAT+BAT*

Discuss Supermodel and your favorite Model 3 games. Show off your latest threads, this is the place to see and be seen.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: Lastest Build WIP r759 Discuss (do not post builds) DAT+

Postby artman999999 » Tue Dec 18, 2018 8:43 am

r717%20SWT%20Screen%20Cap.jpg
r717%20SWT%20Screen%20Cap.jpg (165.94 KiB) Viewed 3099 times
artman999999
 
Posts: 44
Joined: Wed Apr 27, 2016 9:36 am

Re: Lastest Build WIP r759 Discuss (do not post builds) DAT+

Postby Ian » Tue Dec 18, 2018 8:44 am

make a save state and i'll check it out
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r759 Discuss (do not post builds) DAT+

Postby artman999999 » Tue Dec 18, 2018 9:05 am

Ian wrote:make a save state and i'll check it out


Just PM'd the link to it. -A
artman999999
 
Posts: 44
Joined: Wed Apr 27, 2016 9:36 am

Re: Lastest Build WIP r759 Discuss (do not post builds) DAT+

Postby sonic32 » Sun Dec 30, 2018 4:13 am

Hello

Please, May someone add new Dumped Roms to Supermodel (Games.xml)

Dirtdvlsg.zip (German Version of Dirt Devils)
Lostwsgo.zip (Lost World (older revision)

Supermodel would be up to date, all available roms .. :D
User avatar
sonic32
 
Posts: 123
Joined: Tue Dec 20, 2011 11:43 am
Location: Slovakia

Re: Lastest Build WIP r761 Discuss (do not post builds) DAT+

Postby model123 » Tue Jan 15, 2019 5:39 pm

Hello and developer

Polygon object of champagne is lost at Sega Rally 2

Image


The polygon object was visible in the previous version

Image
https://youtu.be/dQhKzbHy6LY?t=712


Save state here
https://www.mediafire.com/file/i7h4i2am0ku00ok/srally2.zip/file


I expect the future progress

Google Translation
model123
 
Posts: 69
Joined: Wed Mar 08, 2017 8:34 am

Re: Lastest Build WIP r761 Discuss (do not post builds) DAT+

Postby Joaquim Gonçalves » Tue Jan 15, 2019 7:16 pm

Nice Find! :D
Hehe Boy!
User avatar
Joaquim Gonçalves
 
Posts: 501
Joined: Wed Dec 10, 2014 5:12 pm
Location: Portugal

Re: Lastest Build WIP r763 Discuss (do not post builds) DAT+

Postby MDashK » Tue Jan 15, 2019 7:36 pm

I posted this on another thread, but I'l leave it here as well.
Just a heads up for a possible bug in the emulator.

Sega Rally 2 DX is running on a much lower speed than it should on stages.
1 second in game goes around 3 seconds in real life.
And even then, there are certain parts of some stages that for a split-second the game gets a speed boost and runs faster, I don't know if this is tied to that specific location of the stage or not, but it's weird...
I'm 100% sure it's not my PC, all other games run fine and with the speed OK, Sega Rally 2 (normal) runs OK without issue, i'm running the emulator on my GTX 950M and nVIDIA overlay confirms the 60 FPS, so it can only be something in the emulator itself.

BTW: this is happening to me on r761
"The only thing necessary for lost data to prevail, is for good men to share nothing."
Alucard, Internet Bible 03:20:1997
User avatar
MDashK
 
Posts: 68
Joined: Wed Jun 13, 2012 10:50 am
Location: Portugal

Re: Lastest Build WIP r763 Discuss (do not post builds) DAT+

Postby Ian » Wed Jan 16, 2019 12:20 am

Thanks for bug reports, will look into them when I have a little time
Model123, can you check which version the water effects disappear at? Should make it easier for me to work out why they aren't drawing

Edit:
never mind I fixed it :p Basically the polys had no normals. They were all set to 0 and got culled. I tweaked it a bit to fix it. Will look into other bug report soon.
Ian
 
Posts: 1632
Joined: Tue Feb 23, 2016 9:23 am

Re: Lastest Build WIP r763 Discuss (do not post builds) DAT+

Postby model123 » Wed Jan 16, 2019 7:53 am

Hello Ian
Thanks for fixing bugs.

Image
model123
 
Posts: 69
Joined: Wed Mar 08, 2017 8:34 am

Re: Lastest Build WIP r764 Discuss (do not post builds) DAT+

Postby model123 » Thu Jan 17, 2019 10:31 am

Hello Developer

Shadows overlap
It may be a rendering bug
I have never seen such a situation with real hardware

Image

Save state here
https://www.mediafire.com/file/u3omw72rl7t46to/vf3tb_2.zip/file



These are not rendering bugs
It is the same as real hardware

Some of the islands of Jeffrey stage flicker

Image


Jeffrey stage has no polygons on Jackie's face

Image


CPU character display is distorted

Image


I expect the future progress

Google Translation
model123
 
Posts: 69
Joined: Wed Mar 08, 2017 8:34 am

PreviousNext

Return to The Catwalk

Who is online

Users browsing this forum: Google [Bot] and 5 guests