Lastest Build WIP r775 Discuss (do not post builds) DAT+BAT*

Discuss Supermodel and your favorite Model 3 games. Show off your latest threads, this is the place to see and be seen.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: Lastest Build WIP r775 Discuss (do not post builds) DAT+

Postby doteater » Wed Mar 27, 2019 5:07 pm

Ian wrote:Save state for sega rally bug?
Tried and failed to replicate that ..


files (included both the save state file and the nv ram)
https://ufile.io/2qrwn

video
https://streamable.com/yo6t0
User avatar
doteater
 
Posts: 54
Joined: Fri Nov 18, 2016 9:24 am

Re: Lastest Build WIP r775 Discuss (do not post builds) DAT+

Postby nuexzz.. » Thu Mar 28, 2019 4:50 pm

svn 775

"PowerPCFrequency=50"
the initial value is 50 and suffers from a slow, if it happens to 49 or 51, this will not happen
User avatar
nuexzz..
 
Posts: 301
Joined: Sun Sep 25, 2011 3:10 pm
Location: Argentina

Re: Lastest Build WIP r775 Discuss (do not post builds) DAT+

Postby doteater » Thu Apr 04, 2019 10:53 am

doteater wrote:
Ian wrote:Save state for sega rally bug?
Tried and failed to replicate that ..


files (included both the save state file and the nv ram)
https://ufile.io/2qrwn

video
https://streamable.com/yo6t0


update :
that graphical glitch always happens but now i know how to "fix" it
you need to let the game complete a full "attract mode" sequence

update 2 :
yea but it shows up somewhere else instead -_-
Last edited by doteater on Sat Apr 06, 2019 9:03 am, edited 1 time in total.
User avatar
doteater
 
Posts: 54
Joined: Fri Nov 18, 2016 9:24 am

Re: Lastest Build WIP r768 Discuss (do not post builds) DAT+

Postby MDashK » Fri Apr 05, 2019 7:04 pm

MDashK wrote:On Sega Rally 2 DX, aside of the timing issue where 1 game second is around 3 real world seconds, I have also found this bug:
https://i.imgur.com/DeP4ryf.png
This is tested on latest r771 version.


Any news on a possible fix for the Sega Rally 2 DX timing issue?
Just making sure it didn't pass under the radar. xD
I also made a video of it, if it helps:
https://mega.nz/#!NhsSEajR!8_4STC9x75P9 ... tdXDR7iyGU

For confirmation sake, I run the game on a i7 CPU with GTX 950M card, with nVIDIA overlay on (which I used to record the video) and I can garantee you the game is running 60 FPS.
Have no similar issues with other game, includ. Sega Rally 2 (standard).
"The only thing necessary for lost data to prevail, is for good men to share nothing."
Alucard, Internet Bible 03:20:1997
User avatar
MDashK
 
Posts: 68
Joined: Wed Jun 13, 2012 10:50 am
Location: Portugal

Re: Lastest Build WIP r768 Discuss (do not post builds) DAT+

Postby doteater » Sat Apr 06, 2019 7:07 am

i can't be 100% sure but i think i noticed something similar in emergency call ambulance (i already mentioned this in another thread)
except it's exactly the opposite - the timer starts going too fast
i don't know if it's a ppc frequency related issue or something else but it's pretty noticeable
i mean,you play perfectly without crashing once and you can barely complete the level (2 if you're wondering)
watched a couple "real hardware" videos and it definitely doesn't happen there
User avatar
doteater
 
Posts: 54
Joined: Fri Nov 18, 2016 9:24 am

Re: Lastest Build WIP r768 Discuss (do not post builds) DAT+

Postby doteater » Fri Apr 19, 2019 1:35 am

well,i am talking to myself at this point but last post about rally 2 and 775 :oops:

the graphical glitch at the starting / finish line happens in stage 2 too
like i said,everything's fine when you first launch the game,then i get this

Image

if i let the game run for a while (at least one full "attract" cycle) then it turns into..something else
i uploaded a video of a run a few days ago
https://www.youtube.com/watch?v=XwwjuuLHjfo

and you can see what i'm descibing at
0:32 on the left
1:32 to 1:35 until it disappears
and same thing from 2:51 to 2:55

this is probably the first time i'm using a non jitterdomer build,i got this r775 file from emu-france so i don't know if they are to blame for this

lastly,i think something's not quite right with transparencies and it is specially evident during the riviera stage
the rear braking lights of the cpu cars are completely visible even when the body of another car should,in theory,"block the view"
here is a screenshot of what i mean

Image

check 4:49 (only for a brief moment)
or 5:05 when it is particularly evident

i will take a look at some footage from real hardware later but i really don't think that's supposed to happen,imo
User avatar
doteater
 
Posts: 54
Joined: Fri Nov 18, 2016 9:24 am

Re: Lastest Build WIP r775 Discuss (do not post builds) DAT+

Postby Ian » Fri Apr 19, 2019 1:57 am

The break lights thing is probably correct. Sega rally for the lens flair effects on the car lights uses the layered poly attribute which forces the polys them to draw over everything else in that priority layer, so I am pretty sure it's correct. Compare against the real h/w and you should see the same.
Ian
 
Posts: 1615
Joined: Tue Feb 23, 2016 9:23 am

Previous

Return to The Catwalk

Who is online

Users browsing this forum: No registered users and 9 guests