Problem with lost world SVN775 Mouse Y axis moves p2 instead

Discuss Supermodel and your favorite Model 3 games. Show off your latest threads, this is the place to see and be seen.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Problem with lost world SVN775 Mouse Y axis moves p2 instead

Postby terminento » Tue May 21, 2019 12:35 pm

Hello everyone, and thank you for the continued and amazing work on supermodel.

I'm having an issue with The Lost World on SVN 775.
Moving the mouse sideways, the player gun moves left to right, but moving the mouse up and down moves P2 gun sideways instead!
Thus, there is no way to move my gun up and down.
I tried SVN 735 with the same config file to see if it was a configuration issue but my mouse works fine as a pointer in that version.

Anyone has any idea on why is this happening? Thanks in advance
User avatar
terminento
 
Posts: 179
Joined: Fri Jun 15, 2012 8:08 am

Re: Problem with lost world SVN775 Mouse Y axis moves p2 ins

Postby Bart » Wed May 22, 2019 12:14 am

terminento wrote:Hello everyone, and thank you for the continued and amazing work on supermodel.

I'm having an issue with The Lost World on SVN 775.
Moving the mouse sideways, the player gun moves left to right, but moving the mouse up and down moves P2 gun sideways instead!
Thus, there is no way to move my gun up and down.
I tried SVN 735 with the same config file to see if it was a configuration issue but my mouse works fine as a pointer in that version.

Anyone has any idea on why is this happening? Thanks in advance


Don't know for sure but I suspect it has something to do with the fact that there are two different gun types: light gun and analog gun. The game works with either. One configuration, I believe, will display a cursor on the screen that some users prefer, which led to Games.xml being modified to use this configuration as the default.

In Games.xml if you see this under the Lost World entry:

Code: Select all
<inputs>
    <input type="common" />
    <input type="analog_gun1" />
    <input type="analog_gun2" />
</inputs>


Try changing it to:

Code: Select all
<inputs>
    <input type="common" />
    <input type="gun1" />
    <input type="gun2" />
</inputs>


Alternatively, run --config-inputs and carefully calibrate the analog guns (as distinct from the light guns).
User avatar
Bart
Site Admin
 
Posts: 2318
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: Problem with lost world SVN775 Mouse Y axis moves p2 ins

Postby terminento » Wed May 22, 2019 1:44 pm

A friendly Supermodel user sent me a fixed games.xml file and it worked like a charm! Thank you all guys for your help.
Now I gotta go save Ian and Sarah...
User avatar
terminento
 
Posts: 179
Joined: Fri Jun 15, 2012 8:08 am

Re: Problem with lost world SVN775 Mouse Y axis moves p2 ins

Postby karadaniano » Sun Jun 16, 2019 3:30 pm

may i ask a link to have that xml? i'm having troubles to save ian and sarah too :oops:
User avatar
karadaniano
 
Posts: 179
Joined: Sat Sep 24, 2011 10:35 pm
Location: Buenos Aires, Argentina

Re: Problem with lost world SVN775 Mouse Y axis moves p2 ins

Postby terminento » Thu Jun 20, 2019 12:08 pm

karadaniano wrote:may i ask a link to have that xml? i'm having troubles to save ian and sarah too :oops:


Of course! Sorry it took me so long. I was kinda busy and couldn't check the forums as often as I'd like to. I uploaded the one I'm using, here's the link:

https://mega.nz/#!w8cmkIQD!99d2q91IV9Z6aatYcx0kha4dkiYuOgApCKZPi1Ece0E

I hope you find it useful, but be careful, "mom is very angry"
User avatar
terminento
 
Posts: 179
Joined: Fri Jun 15, 2012 8:08 am

Re: Problem with lost world SVN775 Mouse Y axis moves p2 ins

Postby karadaniano » Fri Jul 05, 2019 11:37 pm

thank you very much terminento! ian and sarah can now take a little break :D
User avatar
karadaniano
 
Posts: 179
Joined: Sat Sep 24, 2011 10:35 pm
Location: Buenos Aires, Argentina

Re: Problem with lost world SVN775 Mouse Y axis moves p2 ins

Postby terminento » Sun Jul 07, 2019 4:06 am

They went to the laboratory. You can find them with this detector.
LOOK OUT!
(velociraptor music intensifies)
User avatar
terminento
 
Posts: 179
Joined: Fri Jun 15, 2012 8:08 am


Return to The Catwalk

Who is online

Users browsing this forum: Bart, Google [Bot] and 5 guests