The Official Supermodel Work-in-Progress Thread

Discuss Supermodel and your favorite Model 3 games. Show off your latest threads, this is the place to see and be seen.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: The Official Supermodel Work-in-Progress Thread

Postby GambitRogue777 » Sat Jan 21, 2012 7:02 pm

Got a question about Sega Bass Fishing's controls. Are they somehow complex to hook up?

Surprisingly, no Model 3 fanboys care about that game.
Image Image Go, Bonnie, go!
User avatar
GambitRogue777
 
Posts: 73
Joined: Sat Oct 08, 2011 12:04 pm

Re: The Official Supermodel Work-in-Progress Thread

Postby Bart » Sat Jan 21, 2012 7:19 pm

LsrgcBath wrote:I have a question Bart, it´ss about the textures. Even though some games still have these known problems of texture, in the case of Daytona, and particularly in the case of Scud Race ... the textures are working properly, or needs more work in this regard?

something as, if they still were not in a high definition, or bilinear filter not working properly ...

I say this because I still have the impression that some textures, especially in Scud Race asphalt, seem to be a little too much blurry, as if were not in high definition, or bilinear filter not working properly ... I don´t know if you understand what I mean, as if they were not properly decompressed, something like that, maybe


Bilinear filtering is working just fine. It's supposed to blur the textures. At higher resolutions, it may look blurrier. It's possible that the appearance on a real machine is slightly difference due to anti-aliasing, which was probably accomplished by rendering at a higher resolutions and then down-sampling. You have to be careful when comparing to screen shots because these may have been taken with a low quality capture device or, worse yet, with a camera which would blur together multiple frames. Looking at some frame grabs that Abelardo has sent me, which are taken with a camera filming a screen, the road looks more blurry on Model 3. So I think it's mostly a matter of the capture device and the display being used.

Trilinear filtering is not implemented but this only has an effect on textures far from the camera. Trilinear filtering performs additional interpolation between different mipmap levels. Supermodel does not currently implement mipmapping (and will not until I completely rewrite the rendering engine). The lack of mipmapping causes aliasing of fine features, such as narrow lines, at far distances. For example, on Daytona USA 2's expert course, buildings in the distance appear to shimmer as if with a moire pattern (this is due to aliasing -- it wouldn't occur if the appropriate mipmaps were used).

by the way, tried new drivers from AMD today, and OpenGL still a mess, texture errors and all kind of glitchs.. and apparently no hope in have this fixed, so early.


I don't know what's causing this and I don't think I can fix it. But someone else had this problem as well and managed to eliminate it by first completely uninstalling the drivers and performing a fresh installation of the new ones. See here.
User avatar
Bart
Site Admin
 
Posts: 2334
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: The Official Supermodel Work-in-Progress Thread

Postby TheSupermodel3 » Sun Jan 22, 2012 8:21 am

Hi guys,and congratulation for the good work Bart and Nik!

Bart,I downloaded your files and copy it in supermodel folder and whrote this in supermodel.ini:


; FragmentShader="F.glsl" and VertexShader="V.glsl"


Is it correct or not??

I dont noticed a difference!

I opened tread mentioned here,about how lastest ATI drivers sucks with Open GL applications(glitchs,pop up...)


I tried isamu tip,uninstalling properly my drivers 11.12 beta and whql too, and deleted ATI folder in "programme file" ,reboot my PC in safe mod ,run driver sweaper,then reboot again...installing SAME driver...etc

...and it's not working,have same missing textures in 2nd beginig race in scud race/plus,like isamu screens!

Daytona usa 2 too have some glitches in 2nd race!!

May be it's work only with 12.1 preview or 12.1a preview????

Thanks for your help and good luck to you Bart and Nik for this great project!!! :D
- os: 7 /64 bits
- I5 2500k @ 4.5 ghz
- Sapphire HD 7970 @ 1150/1800 mhz
- 8go kingston DDR3 1600 mhz
- ssd crucial m4 128go
- AKASA venom 750 W
- xbox360 wireless pad + Fanatec csr wheel+ G27+ems top gun...
- LED 1080p Samsung 46"
User avatar
TheSupermodel3
 
Posts: 82
Joined: Sat Sep 24, 2011 5:12 pm
Location: France

Re: The Official Supermodel Work-in-Progress Thread

Postby LsrgcBath » Sun Jan 22, 2012 12:40 pm

@ Bart

Yes, always used this method, uninstall CCC, safe mode, then the DriverSweeper, even more, I use CCleaner to clean registry entries and other remnants, always do a search to see if anything was left in the system referring to AMD/ATI.

No way, tested several drivers, both WHQL and beta drivers. From the cataclysm 11.8/11.9, that the problems began. May coud be problems relative to HW specific settings, who knows.

I got a workaround, which is to put the file atioglxx.dll from the Catalyst 11.7, which was the last version that worked without problems here. The errors disappear, but this trick only works in 32bit version of the emulator, in the 64bit version, the atioglxx.dll seems to have no effect in trespassing the OGL installed on the system. Tested using both the 32bit and 64bit versions of atioglxx.dll.

Here, I lose almost 10fps in 32 bit version of the emulator, compared to the 64bit version. I will not complain, are some errors, but I can play and enjoy the emu. When we hav support for dynarec and other improvements, I will play in 32 bit.

I also tested the emu on Mac OS X Lion, and works better than Windows, even tried the new SDL beta, and fullscreen, now works perfectly.I will test the new shaders and see how they look at the Lion.
User avatar
LsrgcBath
 
Posts: 130
Joined: Sat Jan 21, 2012 2:43 pm
Location: Brazil - Sao Paulo

Re: The Official Supermodel Work-in-Progress Thread

Postby nuexzz.. » Sun Jan 22, 2012 1:53 pm

TheSupermodel3 wrote:Hi guys,and congratulation for the good work Bart and Nik!

Bart,I downloaded your files and copy it in supermodel folder and whrote this in supermodel.ini:


; FragmentShader="F.glsl" and VertexShader="V.glsl"


Is it correct or not??

I dont noticed a difference!

I opened tread mentioned here,about how lastest ATI drivers sucks with Open GL applications(glitchs,pop up...)


I tried isamu tip,uninstalling properly my drivers 11.12 beta and whql too, and deleted ATI folder in "programme file" ,reboot my PC in safe mod ,run driver sweaper,then reboot again...installing SAME driver...etc

...and it's not working,have same missing textures in 2nd beginig race in scud race/plus,like isamu screens!

Daytona usa 2 too have some glitches in 2nd race!!

May be it's work only with 12.1 preview or 12.1a preview????

Thanks for your help and good luck to you Bart and Nik for this great project!!! :D



I in particular have created a bat file with the following contents

Code: Select all
supermodel.exe  daytona2.zip   -vert-shader=v.glsl -frag-shader=F.glsl


I have the rom "daytona2.zip", along with supermodel
User avatar
nuexzz..
 
Posts: 302
Joined: Sun Sep 25, 2011 3:10 pm
Location: Argentina

Re: The Official Supermodel Work-in-Progress Thread

Postby Bart » Sun Jan 22, 2012 2:21 pm

TheSupermodel3 wrote:Hi guys,and congratulation for the good work Bart and Nik!

Bart,I downloaded your files and copy it in supermodel folder and whrote this in supermodel.ini:


; FragmentShader="F.glsl" and VertexShader="V.glsl"


Is it correct or not??


Nope. Read what nuexzz wrote. To modify the config file so that they are always active, you need to put those two settings on their own lines in the Global section, like this:

Code: Select all
FragmentShader="F.glsl"
VertexShader="V.glsl"


Semicolons denote comments and will cause the parser to ignore the entire line.
User avatar
Bart
Site Admin
 
Posts: 2334
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: The Official Supermodel Work-in-Progress Thread

Postby Bart » Sun Jan 22, 2012 4:22 pm

GambitRogue777 wrote:Got a question about Sega Bass Fishing's controls. Are they somehow complex to hook up?

Surprisingly, no Model 3 fanboys care about that game.


Not sure. I haven't tried hooking them up because I think there are some other issues with the game preventing it from being playable. I'll take a look at it at some point.
User avatar
Bart
Site Admin
 
Posts: 2334
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: The Official Supermodel Work-in-Progress Thread

Postby TheSupermodel3 » Mon Jan 23, 2012 4:14 am

Thanks BART,it's working good and looks like an HDR effect in 1920x1080 res + SSAAx8,very good man!! :D

Finaly ,i returned to catalyst 11.8 whql and all runs very good with no glitches and a solid 60 fps in all games and other emulators too!

After 11.8,all new ATI drivers(11.10...12.1a preview) have same error with OGL app... :evil:

Viva supermodel!!!! :D
- os: 7 /64 bits
- I5 2500k @ 4.5 ghz
- Sapphire HD 7970 @ 1150/1800 mhz
- 8go kingston DDR3 1600 mhz
- ssd crucial m4 128go
- AKASA venom 750 W
- xbox360 wireless pad + Fanatec csr wheel+ G27+ems top gun...
- LED 1080p Samsung 46"
User avatar
TheSupermodel3
 
Posts: 82
Joined: Sat Sep 24, 2011 5:12 pm
Location: France

Re: The Official Supermodel Work-in-Progress Thread

Postby Bart » Tue Jan 24, 2012 2:21 am

I started looking into specular lighting today. Specular lighting basically makes things look shiny or glossy.

I'm fairly confident that some of the polygon header bits that control it have been located (in fact, Stefano Teso identified the bit fields way back in the days of the original Supermodel project but he wasn't sure what they did). I coded up specular lighting in the shaders but I'm still unsure of how the shininess factor is encoded. I'm also wondering if there are some problems with my lighting vectors because the specular highlights are occasionally absent during key times when they are employed as special effects. For example, at the start of the night-time beginner course in Scud Race when driving under the terminal, the vehicle is supposed to be lit up from above and I strongly suspect this is a trick achieved with specular highlights.

I've had the best luck with Daytona USA 2 by decoding what I think is the shininess factor a particular way. Other games don't seem to like it, unfortunately. Below are some screenshots. Note the presence of additional light reflecting off the black surface of the vehicle. By contrast, In Supermodel v0.2a, black pixels remain black no matter what the lighting conditions are. I'll keep you guys updated. It's a relatively minor detail but something that I've been wanting to figure out since I began the rewrite last year. Hopefully it'll be working in v0.3a. :)
Attachments
Dayto2PE_Spec_1.png
Shiny Phantom car.
Dayto2PE_Spec_1.png (211.2 KiB) Viewed 15423 times
Dayto2PE_Spec_0.png
Shiny cars.
Dayto2PE_Spec_0.png (124.28 KiB) Viewed 15423 times
User avatar
Bart
Site Admin
 
Posts: 2334
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: The Official Supermodel Work-in-Progress Thread

Postby venomv1986 » Tue Jan 24, 2012 3:44 am

Wanted to ask you if you have figured out the slowdown source in VF3TB?
Cause it runs with very little glitches but very slowly.
Image
User avatar
venomv1986
 
Posts: 93
Joined: Fri Nov 04, 2011 2:41 am

PreviousNext

Return to The Catwalk

Who is online

Users browsing this forum: No registered users and 5 guests

cron