Error compiling r519 with Linux Mint 18

Linux geeks and Mac OS hipsters unite! A board for discussion of Supermodel on non-Windows platforms.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Error compiling r519 with Linux Mint 18

Postby Shoegazer » Fri Feb 10, 2017 8:30 am

Hello, I'm having difficulties compiling r519 with Linux Mint 18.1/GCC6.2.0. Bart, can you (or anyone) help please?

Thanks...

Code: Select all
Src/Graphics/New3D/New3D.cpp:1529:45: error: ‘memcpy’ was not declared in this scope
    memcpy(in, poly.p1.pos, sizeof(float) * 3);
                                             ^
Makefile:189: recipe for target 'obj/New3D.o' failed
make: *** [obj/New3D.o] Error 1
Shoegazer
 
Posts: 6
Joined: Fri Oct 14, 2016 5:51 pm

Re: Error compiling r519 with Linux Mint 18

Postby Ian » Sat Feb 11, 2017 6:53 am

#include <string.h>

at the top of new3d.cpp
Ian
 
Posts: 1131
Joined: Tue Feb 23, 2016 9:23 am

Re: Error compiling r519 with Linux Mint 18

Postby sergio-br2 » Thu Feb 16, 2017 1:29 pm

I was going to report it too, heh.

It's building again in the ubuntu PPA
sergio-br2
 
Posts: 22
Joined: Wed May 27, 2015 7:14 pm

Re: Error compiling r519 with Linux Mint 18

Postby Shoegazer » Fri Feb 17, 2017 7:37 am

Thanks! Can someone merge this quick compilation fix and the other one posted from r494 (see five forum topics down) into the source? If so, even better. ;)
Shoegazer
 
Posts: 6
Joined: Fri Oct 14, 2016 5:51 pm


Return to Alternative Fashion

Who is online

Users browsing this forum: No registered users and 1 guest