[Patch] Textures

Technical discussion for those interested in Supermodel development and Model 3 reverse engineering. Prospective contributors welcome.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: [Patch] Textures

Postby YoYo09 » Mon Dec 18, 2017 4:26 am

Ian wrote:Sounds like it crashed
can you make a save state just before it crashes?


save file here
https://drive.google.com/file/d/1Ymi7Uh ... sp=sharing
YoYo09
 
Posts: 67
Joined: Mon Nov 28, 2016 7:43 pm

Re: [Patch] Textures

Postby Ian » Mon Dec 18, 2017 4:48 am

It doesn't crash here .. :/
Maybe the unofficial build is bad
Ian
 
Posts: 1535
Joined: Tue Feb 23, 2016 9:23 am

Re: [Patch] Textures

Postby Ian » Mon Dec 18, 2017 12:47 pm

Can someone else test this? Because I couldn't replicate this with either my debug or release build
Ian
 
Posts: 1535
Joined: Tue Feb 23, 2016 9:23 am

Re: [Patch] Textures

Postby HarryTuttle » Mon Dec 18, 2017 1:50 pm

I'm going to test this later, after I catch up whit the last 3 commits. But before that: Ian I saw in r681 that you enabled the dump functionality in Real3D.cpp, could it be that?
User avatar
HarryTuttle
 
Posts: 646
Joined: Thu Mar 09, 2017 8:57 am

Re: [Patch] Textures

Postby Ian » Mon Dec 18, 2017 2:59 pm

Oops that should be removed. Shouldn't make it crash though
Ian
 
Posts: 1535
Joined: Tue Feb 23, 2016 9:23 am

Re: [Patch] Textures

Postby HarryTuttle » Mon Dec 18, 2017 3:20 pm

HarryTuttle wrote:I'm going to test this later

Quick update for YoYo09 and Ian: no problem here with the official build, either starting a new game or loading the savestate.
User avatar
HarryTuttle
 
Posts: 646
Joined: Thu Mar 09, 2017 8:57 am

Re: [Patch] Textures

Postby YoYo09 » Mon Dec 18, 2017 6:46 pm

Ian wrote:Can someone else test this? Because I couldn't replicate this with either my debug or release build


I got a build of another person (Emucr) and tested it.
there was no problem..
I think it's a compilation problem.

thank you Ian , Harry
YoYo09
 
Posts: 67
Joined: Mon Nov 28, 2016 7:43 pm

Re: [Patch] Textures

Postby Spindizzi » Tue Dec 19, 2017 12:10 am

YoYo09 wrote:
Ian wrote:Can someone else test this? Because I couldn't replicate this with either my debug or release build


I got a build of another person (Emucr) and tested it.
there was no problem..
I think it's a compilation problem.

thank you Ian , Harry


Confirming, bad build :oops:
vc2017 dislike svn681 (however, 680 working ??), it crashed with lemans and von2. I had to change a build option in optimisation code
Spindizzi
 
Posts: 122
Joined: Thu Nov 17, 2016 8:55 am
Location: France

Re: [Patch] Textures

Postby Ian » Tue Dec 19, 2017 2:23 am

It's more than likely a bug in our code, probably array out of bounds at a guess. Can you try with the legacy engine too see if that crashes with that particular build
Ian
 
Posts: 1535
Joined: Tue Feb 23, 2016 9:23 am

Re: [Patch] Textures

Postby Spindizzi » Tue Dec 19, 2017 6:27 am

It crashes also with legacy render
firstly, i thought about a bad code in uploadtexture, I see many optimisations changes here or a div by 0 somewhere, but apparently not
von2 crashed after displaying green frame (stage 1), and before displaying pictures Inside this green frame
lemans crashed just after (or during) initialize system display, right before the warning page
May be related, vc2017 has been updated 4 days ago :idea:
Spindizzi
 
Posts: 122
Joined: Thu Nov 17, 2016 8:55 am
Location: France

PreviousNext

Return to The Dark Room

Who is online

Users browsing this forum: No registered users and 6 guests