Possibly a bit of a stupid question, but...

Technical discussion for those interested in Supermodel development and Model 3 reverse engineering. Prospective contributors welcome.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Re: Possibly a bit of a stupid question, but...

Postby MrThunderwing » Wed Apr 04, 2012 3:47 am

nikdd wrote:
barrazita2 wrote:oye nuexzz, ami tambien me sale el mismo error al momento de abrir el projecto, por lo tanto creo que sea problema de si es de 32 o 64 bits


Si, parece que es asi. Para solucionarlo y poder compilar a 64-bits, creo que habria que instalar Windows Software Development Kit (http://msdn.microsoft.com/en-us/windows ... 80924.aspx) como he dicho anteriormente. Cuando se instala Visual Studio 2010 Express lo normal es que falte este componente.

Saludos, Nik.


Hi, hope I'm not teaching anyone how to suck eggs here, but this sounds very similar to the problem I was having above, where I could compile a 32 bit build but not a 64 bit one. I had to install a further bit of software from the VS2008 DVD I'd burned in order to get it working - there was a single box that was unchecked by default to install the 64 bit compiler. Once that installed I was sorted!
User avatar
MrThunderwing
 
Posts: 547
Joined: Fri Sep 02, 2011 11:31 am
Location: Bristol, UK

Re: Possibly a bit of a stupid question, but...

Postby nikdd » Wed Apr 04, 2012 4:30 am

Hey Mr Thunderwing,

MrThunderwing wrote:Hi, hope I'm not teaching anyone how to suck eggs here, but this sounds very similar to the problem I was having above, where I could compile a 32 bit build but not a 64 bit one. I had to install a further bit of software from the VS2008 DVD I'd burned in order to get it working - there was a single box that was unchecked by default to install the 64 bit compiler. Once that installed I was sorted!


Yes, it's certainly similar. The difference with VS2010 Express Edition though is that, as far as I'm aware, an option to install the 64-bit build platform is not available in the standard installer (although someone correct me if I'm wrong). For this reason, it is necessary to download the SDK and install that afterwards. I guess I should add a note about this to the build steps thread, if someone can confirm it for me.

The other difference is that neuxzz's problem was occurring while he was upgrading the VS2008 project to VS2010 (this is necessary before VS2010 will load it), meaning he was not even able to get to the point where he could compile it (32-bits or 64-bits). So, I might ask anyone who has upgraded the solution successfully to send me their solution and project files so that I can add them to the SVN repository. This way people running VS2010 can load these instead of having to open and upgrade the VS2008 ones.

Cheers, Nik.
nikdd
 
Posts: 180
Joined: Fri Sep 02, 2011 10:39 am
Location: London

Re: Possibly a bit of a stupid question, but...

Postby nuexzz.. » Wed Apr 04, 2012 11:13 am

(visual 2010)

after the Windows Software Development Kit , I can only I can compile in 32.
when I try to average 64 on conversion "error"

steps http://www.mediafire.com/?nen9ayrucn6wjld
User avatar
nuexzz..
 
Posts: 303
Joined: Sun Sep 25, 2011 3:10 pm
Location: Argentina

Re: Possibly a bit of a stupid question, but...

Postby nuexzz.. » Mon Apr 23, 2012 4:26 pm

I am still unable to compile the 64bit.
I'm getting this error when I indicated the routes of the SDKs lib

Code: Select all
5>..\Src\CPU\68K\Musashi\m68kcpu.c(69): fatal error C1083: Cannot open include file: 'm68kops.h': No such file or directory
5>  m68kopac.c
5>c1 : fatal error C1083: Cannot open source file: '..\Src\CPU\68K\Musashi\m68kopac.c': No such file or directory
5>  m68kopdm.c
5>c1 : fatal error C1083: Cannot open source file: '..\Src\CPU\68K\Musashi\m68kopdm.c': No such file or directory
5>  m68kopnz.c
5>c1 : fatal error C1083: Cannot open source file: '..\Src\CPU\68K\Musashi\m68kopnz.c': No such file or directory
5>  m68kops.c
5>c1 : fatal error C1083: Cannot open source file: '..\Src\CPU\68K\Musashi\m68kops.c': No such file or directory
========== Build: 2 succeeded, 3 failed, 0 up-to-date, 0 skipped ==========


any ideas?
User avatar
nuexzz..
 
Posts: 303
Joined: Sun Sep 25, 2011 3:10 pm
Location: Argentina

Re: Possibly a bit of a stupid question, but...

Postby nikdd » Tue Apr 24, 2012 1:55 am

Hola nuexzz,

nuexzz.. wrote:I am still unable to compile the 64bit. I'm getting this error when I indicated the routes of the SDKs lib


Apologies for not looking at this sooner but I missed your original post.

It's difficult to know what exactly is going wrong here without some more info but it appears that either the Musashi68K project that Supermodel includes is not being built or its post-build steps are not being run for some reason.

What I suggest you do is try the following two things:

1) First, clean the solution with the "Build->Clean Solution" item in the main menu. Next, right mouse click on the Musashi68K project in the Solution Explorer and select "Build Project". If that builds with no errors then build the rest of the solution with "Build->Build Solution" in the main menu.

If it all runs to completion and without any errors then the problem is that in the Configuration Manager the Musashi68K project is not set to be built for the x64 build platform. Presumably the setting got lost when converting the solution to VS2010 from VS2008 for some unknown reason. To permanently fix it you'll need to use the Configuration Manager to alter it to be built every time the solution is.

2) If the above doesn't help then the problem must be that the post-build event for the Musashi68K project is not running properly. The purpose of this event is to run the Musashi executable that gets built and copy its output files into the main build folder. To check that it is configured properly, right mouse button on the Musashi68K project and select "Properties". Make sure "Platform" is set to x64 and then navigate to "Build Events->Post-Build Event". In the "Command Line" textbox check that it says the following:

Code: Select all
"$(TargetPath)" ..\..\Src\CPU\68K\Musashi\..\..\Src\CPU\68K\Musashi\m68k_in.c


If not, update it and then clean and rebuild the solution with the "Build->Clean Solution" and "Build->Build Solution" options in the main menu.

NOTE: these steps are from memory and for VS2008 so they might differ slightly for you on VS2010 but you should be able to work out what to do.

Good luck and hope that helps! Nik.
nikdd
 
Posts: 180
Joined: Fri Sep 02, 2011 10:39 am
Location: London

Re: Possibly a bit of a stupid question, but...

Postby nuexzz.. » Tue Apr 24, 2012 4:54 am

Nik as always thank you very much for your advice.
All These steps after doing as you said, the problems still there Were

as you know I'm an amateur and I downloaded a trial version (30 days) Microsoft Greatly limit Is That These versions and the only way to get the job is very advanced Being a user (not me)

I finally got the job .. yeah!!!!

after installing a patch. this is very basic and is simply a cmd

steps are as FOLLOWS

1-Visual c + + 2010
2 - Windows SDK for Windows 7 and. NET framework 3.5
3-Patch http://www.cppblog.com/Files/xcpp/VCE64BIT_WIN7SDK.zip (use at your own risk "adds records to the SO")

hope this helps another user.

thanks again NIK. daytona2 now I have it running at 60 fps constants!!
User avatar
nuexzz..
 
Posts: 303
Joined: Sun Sep 25, 2011 3:10 pm
Location: Argentina

Re: Possibly a bit of a stupid question, but...

Postby nikdd » Tue Apr 24, 2012 4:59 am

Hola nuexzz,

nuexzz.. wrote:steps are as FOLLOWS

1-Visual c + + 2010
2 - Windows SDK for Windows 7 and. NET framework 3.5
3-Patch http://www.cppblog.com/Files/xcpp/VCE64BIT_WIN7SDK.zip (use at your own risk "adds records to the SO")


Great - glad you got it sorted :-) ! Hopefully your steps will help other users of VS2010 too.

nuexzz.. wrote:thanks again NIK. daytona2 now I have it running at 60 fps constants!!


De nada amigo! Have fun with Daytona :-)

Cheers, Nik.
nikdd
 
Posts: 180
Joined: Fri Sep 02, 2011 10:39 am
Location: London

Previous

Return to The Dark Room

Who is online

Users browsing this forum: No registered users and 2 guests

cron