Help in getting it work (Solved)

Having technical difficulties with Supermodel? Last-minute wardrobe malfunction? Get help here.
Forum rules
Keep it classy!

  • No ROM requests or links.
  • Do not ask to be a play tester.
  • Do not ask about release dates.
  • No drama!

Help in getting it work (Solved)

Postby MattiaLimonta » Fri Dec 07, 2018 5:13 am

Good evening everyone!
I am new to this forum, I did set up Supermodel correctly in the past to play Sega Rally 2, but a month ago my PC broke and I lost all the datas.
Today I am trying to set it up back, but everytime I try to get it to work it says "Could not open srally2" or any other game... Can anyone help me?
Thank you! :)
Last edited by MattiaLimonta on Thu Dec 13, 2018 10:48 am, edited 1 time in total.
User avatar
MattiaLimonta
 
Posts: 6
Joined: Wed Sep 27, 2017 12:21 am

Re: Help in getting it work

Postby Bart » Sat Dec 08, 2018 7:47 pm

How about starting here and following those directions precisely?
User avatar
Bart
Site Admin
 
Posts: 2347
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: Help in getting it work

Postby MattiaLimonta » Sun Dec 09, 2018 3:30 am

Yes, I finally figured it out (I didn't click on "run as administrator" in the properties section of the Supermodel.exe). Now I have another problem with the latest revision. I am currently running the r520, because with the r757 when I load the ROM it says "Init net board..." and then everything closes up.
I don't need the net board emulation, How can I set every game to run as a single arcade? (Like Daytona 2 in the earlier revisions from the test menu)

Thank you so much!
Greetings from Italy! :)
User avatar
MattiaLimonta
 
Posts: 6
Joined: Wed Sep 27, 2017 12:21 am

Re: Help in getting it work

Postby MattiaLimonta » Sun Dec 09, 2018 3:38 am

Here I posted the error.log and a screenshot.

Thanks! :)

Supermodel v0.3a-WIP Error Log
------------------------------

Started as:
argv[0] = C:\Supermodel-x64\Supermodel.exe
argv[1] = srally2.zip

Opened srally2.zip.
srally2:
banked_crom: stride=zu, chunk size=zu, byte swap=8
mpr-20605.4, crc32=0x00513401, offset=0x00000000
mpr-20605.3, crc32=0x99c5f396, offset=0x00000002
mpr-20603.2, crc32=0xad0d8eb8, offset=0x00000004
mpr-20602.1, crc32=0x60cfa72a, offset=0x00000006
mpr-20609.8, crc32=0xc03cc0e5, offset=0x01000000
mpr-20608.7, crc32=0x0c9b0571, offset=0x01000002
mpr-20607.6, crc32=0x6da85aa3, offset=0x01000004
mpr-20606.5, crc32=0x072498fd, offset=0x01000006
mpr-20613.12, crc32=0x2938c0d9, offset=0x02000000
mpr-20612.11, crc32=0x721a44b6, offset=0x02000002
mpr-20611.10, crc32=0x5d9f8ba2, offset=0x02000004
mpr-20610.9, crc32=0xb6e0ff4e, offset=0x02000006
crom: stride=zu, chunk size=zu, byte swap=8
epr-20635.20, crc32=0x7937473f, offset=0x00000000
epr-20634.19, crc32=0x45a09245, offset=0x00000002
epr-20633.18, crc32=0xf5a24f24, offset=0x00000004
epr-20632.17, crc32=0x6829a801, offset=0x00000006
driveboard_program: stride=zu, chunk size=zu, byte swap=1
epr-20512.bin, crc32=0xcf64350d, offset=0x00000000
mpeg_music: stride=zu, chunk size=zu, byte swap=1
mpr-20637.57, crc32=0xd66e8a02, offset=0x00000000
mpr-20638.58, crc32=0xd1513382, offset=0x00400000
mpr-20639.59, crc32=0xf6603b7b, offset=0x00800000
mpr-20640.60, crc32=0x9eea07b7, offset=0x00c00000
mpeg_program: stride=zu, chunk size=zu, byte swap=1
epr-20641.2, crc32=0xc9b82035, offset=0x00000000
sound_program: stride=zu, chunk size=zu, byte swap=1
epr-20636.21, crc32=0x7139ebf8, offset=0x00000000
sound_samples: stride=zu, chunk size=zu, byte swap=1
mpr-20614.22, crc32=0xa3930e4a, offset=0x00000000
mpr-20615.24, crc32=0x62e8a94a, offset=0x00400000
vrom: stride=zu, chunk size=zu, byte swap=32
mpr-20616.26, crc32=0xe11dcf8b, offset=0x00000000
mpr-20617.27, crc32=0x96acef3f, offset=0x00000002
mpr-20618.28, crc32=0x6c281281, offset=0x00000004
mpr-20619.29, crc32=0x0fa65819, offset=0x00000006
mpr-20620.30, crc32=0xee79585f, offset=0x00000008
mpr-20621.31, crc32=0x3a99148f, offset=0x0000000a
mpr-20622.32, crc32=0x0618f056, offset=0x0000000c
mpr-20623.33, crc32=0xccf31b85, offset=0x0000000e
mpr-20624.34, crc32=0x90f30936, offset=0x00000010
mpr-20625.35, crc32=0x04f804fa, offset=0x00000012
mpr-20626.36, crc32=0x2d6c97d6, offset=0x00000014
mpr-20627.37, crc32=0xa14ee871, offset=0x00000016
mpr-20628.38, crc32=0xbba829a3, offset=0x00000018
mpr-20629.39, crc32=0xead2eb31, offset=0x0000001a
mpr-20630.40, crc32=0xcc5881b8, offset=0x0000001c
mpr-20631.41, crc32=0x5cb69ffd, offset=0x0000001e
Runtime configuration:
GameXMLFile=Config/Games.xml
InitStateFile=
MultiThreaded=1
GPUMultiThreaded=1
PowerPCFrequency=50
MultiTexture=0
VertexShader=
FragmentShader=
VertexShaderFog=
FragmentShaderFog=
VertexShader2D=
FragmentShader2D=
EmulateSound=1
Balance=0
EmulateDSB=1
SoundVolume=100
MusicVolume=100
ForceFeedback=0
New3DEngine=1
QuadRendering=0
XResolution=1920
YResolution=1080
FullScreen=0
WideScreen=0
Stretch=0
VSync=0
Throttle=1
ShowFrameRate=0
Crosshairs=0
FlipStereo=0
InputSystem=dinput
DirectInputConstForceLeftMax=100
DirectInputConstForceRightMax=100
DirectInputSelfCenterMax=100
DirectInputFrictionMax=100
DirectInputVibrateMax=100
XInputConstForceThreshold=30
XInputConstForceMax=100
XInputVibrateMax=100
EmulateNet=0
Outputs=none
Fullscreen=0
Attachments
Screenshot (6).png
Screenshot (6).png (14.34 KiB) Viewed 2843 times
User avatar
MattiaLimonta
 
Posts: 6
Joined: Wed Sep 27, 2017 12:21 am

Re: Help in getting it work

Postby Bart » Sun Dec 09, 2018 5:07 pm

Where did you get this build from? You should not have to run as administrator...

Also, net board emulation appears to be disabled, according to the log.
User avatar
Bart
Site Admin
 
Posts: 2347
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: Help in getting it work

Postby MattiaLimonta » Mon Dec 10, 2018 8:10 am

I downloaded this build from the Mediafire archive that is available on a thread here in the forum. Maybe the "Run as admin" issue is a Win10 related thing. About the r757, so the problem isn't the net board? Why games doesn't boot?
User avatar
MattiaLimonta
 
Posts: 6
Joined: Wed Sep 27, 2017 12:21 am

Re: Help in getting it work

Postby Bart » Mon Dec 10, 2018 11:17 pm

Interesting. All along I've been building Supermodel without network board emulation. I just tried building it and experienced a crash with this error:

Code: Select all
terminate called after throwing an instance of 'std::range_error'
  what():  Node "port_in" does not exist


No problem. Just add the following to Supermodel.ini:

Code: Select all
port_in = 0
port_out = 0
addr_out = 0


Then, run Supermodel like this:

Code: Select all
supermodel srally2.zip -no-net


Works fine for me.

If you can find a build that doesn't include network board support at all, that would probably be a better option for you.
User avatar
Bart
Site Admin
 
Posts: 2347
Joined: Thu Sep 01, 2011 2:13 pm
Location: Santa Clara, California

Re: Help in getting it work

Postby MattiaLimonta » Wed Dec 12, 2018 12:42 pm

Thanks! I will try it! :)
User avatar
MattiaLimonta
 
Posts: 6
Joined: Wed Sep 27, 2017 12:21 am

Re: Help in getting it work

Postby MattiaLimonta » Wed Dec 12, 2018 12:47 pm

Great! It works perfectly! :)

Thanks again!
User avatar
MattiaLimonta
 
Posts: 6
Joined: Wed Sep 27, 2017 12:21 am


Return to The Fitting Room

Who is online

Users browsing this forum: No registered users and 3 guests